Hi. I am not sure why this is not working, but I am now unable to use the ceph command on any of my hosts. When I try to launch ceph, I get the following response: [errno 13] RADOS permission denied (error connecting to the cluster) The web management interface is working fine. I have a suspicion that this started after trying to recreate an nfs cluster I first removed the existing one with: ceph nfs cluster delete <id> And then tried to create it again with: ceph nfs cluster create cephfs <id> The command seemed to hang, and after several hours I ended the command with ctrl-c. Since then I have been unable to use the ceph command. This is fortunately a test environment, and it is running Octopus 15.2.8 Does anyone have an idea on how I can get access again? Regards Jens Hyllegaard
Do you have mon containers running so they can form a quorum? Do your hosts still have a (at least) minimal ceph.conf? Zitat von "Jens Hyllegaard (Soft Design A/S)" <jens.hyllegaard@softdesign.dk>:
Hi.
I am not sure why this is not working, but I am now unable to use the ceph command on any of my hosts.
When I try to launch ceph, I get the following response: [errno 13] RADOS permission denied (error connecting to the cluster)
The web management interface is working fine.
I have a suspicion that this started after trying to recreate an nfs cluster I first removed the existing one with: ceph nfs cluster delete <id> And then tried to create it again with: ceph nfs cluster create cephfs <id> The command seemed to hang, and after several hours I ended the command with ctrl-c. Since then I have been unable to use the ceph command.
This is fortunately a test environment, and it is running Octopus 15.2.8
Does anyone have an idea on how I can get access again?
Regards
Jens Hyllegaard _______________________________________________ ceph-users mailing list -- ceph-users@ceph.io To unsubscribe send an email to ceph-users-leave@ceph.io
According to the management interface, everything is OK. There are 3 monitors in quorum. I am running this on docker. Perhaps I should have a look at the containers and see if their information is different than what is in /etc/ceph on the hosts Regards Jens -----Original Message----- From: Eugen Block <eblock@nde.ag> Sent: 26. januar 2021 15:43 To: ceph-users@ceph.io Subject: [ceph-users] Re: Unable to use ceph command Do you have mon containers running so they can form a quorum? Do your hosts still have a (at least) minimal ceph.conf? Zitat von "Jens Hyllegaard (Soft Design A/S)" <jens.hyllegaard@softdesign.dk>:
Hi.
I am not sure why this is not working, but I am now unable to use the ceph command on any of my hosts.
When I try to launch ceph, I get the following response: [errno 13] RADOS permission denied (error connecting to the cluster)
The web management interface is working fine.
I have a suspicion that this started after trying to recreate an nfs cluster I first removed the existing one with: ceph nfs cluster delete <id> And then tried to create it again with: ceph nfs cluster create cephfs <id> The command seemed to hang, and after several hours I ended the command with ctrl-c. Since then I have been unable to use the ceph command.
This is fortunately a test environment, and it is running Octopus 15.2.8
Does anyone have an idea on how I can get access again?
Regards
Jens Hyllegaard _______________________________________________ ceph-users mailing list -- ceph-users@ceph.io To unsubscribe send an email to ceph-users-leave@ceph.io
_______________________________________________ ceph-users mailing list -- ceph-users@ceph.io To unsubscribe send an email to ceph-users-leave@ceph.io
That's worth a look, I had an issue when upgrading an older cluster to Octopus where I had to change some config file within the container. Zitat von "Jens Hyllegaard (Soft Design A/S)" <jens.hyllegaard@softdesign.dk>:
According to the management interface, everything is OK. There are 3 monitors in quorum. I am running this on docker. Perhaps I should have a look at the containers and see if their information is different than what is in /etc/ceph on the hosts
Regards
Jens
-----Original Message----- From: Eugen Block <eblock@nde.ag> Sent: 26. januar 2021 15:43 To: ceph-users@ceph.io Subject: [ceph-users] Re: Unable to use ceph command
Do you have mon containers running so they can form a quorum? Do your hosts still have a (at least) minimal ceph.conf?
Zitat von "Jens Hyllegaard (Soft Design A/S)" <jens.hyllegaard@softdesign.dk>:
Hi.
I am not sure why this is not working, but I am now unable to use the ceph command on any of my hosts.
When I try to launch ceph, I get the following response: [errno 13] RADOS permission denied (error connecting to the cluster)
The web management interface is working fine.
I have a suspicion that this started after trying to recreate an nfs cluster I first removed the existing one with: ceph nfs cluster delete <id> And then tried to create it again with: ceph nfs cluster create cephfs <id> The command seemed to hang, and after several hours I ended the command with ctrl-c. Since then I have been unable to use the ceph command.
This is fortunately a test environment, and it is running Octopus 15.2.8
Does anyone have an idea on how I can get access again?
Regards
Jens Hyllegaard _______________________________________________ ceph-users mailing list -- ceph-users@ceph.io To unsubscribe send an email to ceph-users-leave@ceph.io
_______________________________________________ ceph-users mailing list -- ceph-users@ceph.io To unsubscribe send an email to ceph-users-leave@ceph.io
Hi, Am 26.01.21 um 14:58 schrieb Jens Hyllegaard (Soft Design A/S):
I am not sure why this is not working, but I am now unable to use the ceph command on any of my hosts.
When I try to launch ceph, I get the following response: [errno 13] RADOS permission denied (error connecting to the cluster)
This issue is mostly caused by not having a readable ceph.conf and ceph.client.admin.keyring file in /etc/ceph for the user that starts the ceph command. Regards -- Robert Sander Heinlein Support GmbH Schwedter Str. 8/9b, 10119 Berlin http://www.heinlein-support.de Tel: 030 / 405051-43 Fax: 030 / 405051-19 Zwangsangaben lt. §35a GmbHG: HRB 93818 B / Amtsgericht Berlin-Charlottenburg, Geschäftsführer: Peer Heinlein -- Sitz: Berlin
Hi. I think you are right. I suspect that somehow the /etc/ceph/ceph.client.admin.keyring file disappeared on all the hosts. I ended up reinstalling the cluster. Thank you for your input. Regards Jens -----Original Message----- From: Robert Sander <r.sander@heinlein-support.de> Sent: 29. januar 2021 13:29 To: ceph-users@ceph.io Subject: [ceph-users] Re: Unable to use ceph command Hi, Am 26.01.21 um 14:58 schrieb Jens Hyllegaard (Soft Design A/S):
I am not sure why this is not working, but I am now unable to use the ceph command on any of my hosts.
When I try to launch ceph, I get the following response: [errno 13] RADOS permission denied (error connecting to the cluster)
This issue is mostly caused by not having a readable ceph.conf and ceph.client.admin.keyring file in /etc/ceph for the user that starts the ceph command. Regards -- Robert Sander Heinlein Support GmbH Schwedter Str. 8/9b, 10119 Berlin http://www.heinlein-support.de Tel: 030 / 405051-43 Fax: 030 / 405051-19 Zwangsangaben lt. §35a GmbHG: HRB 93818 B / Amtsgericht Berlin-Charlottenburg, Geschäftsführer: Peer Heinlein -- Sitz: Berlin
participants (3)
-
Eugen Block
-
Jens Hyllegaard (Soft Design A/S)
-
Robert Sander