Re: Issue about rbd image(disable feature journaling failed)
"rbd status" will tell you which IP addresses have the image open. "rbd lock ls" will show you who owns the lock. On Wed, Mar 24, 2021 at 9:07 AM Edgelong Voodu <1070443499cs@gmail.com> wrote:
Hi, As info mentioned in the log file There still a lock owner alive. The question is how to find out the alive owner and what is the root cause about this. Why cannot acquire lock to the owner? Thank you so much
Jason Dillaman <jdillama@redhat.com>于2021年3月24日 周三20:55写道:
It sounds like this is a non-primary mirrored image, which means it's read-only and cannot be modified. A quick "rbd info" will tell you the mirror state. Instead, you would need to force-promote it to primary via "rbd mirror image promote --force" before attempting to modify the image.
On Wed, Mar 24, 2021 at 3:44 AM Edgelong Voodu <1070443499cs@gmail.com> wrote:
hi , dillaman: i was confused nowadays, when i execute the rbd feature disable <image> journaling, the result of this often shows me : rbd: failed to update image features: (30) Read-only file system i use the rbd-mirror for replicate data between two clouster. i thought the rbd-mirror could be the reason. but i have no idea about it. could you give some advise ? some log when execute rbd command also send you.
-- Jason
-- 发自移动版 Gmail
-- Jason
participants (1)
-
Jason Dillaman