Hi, issue is solved now after executing this command: # ceph auth get-or-create client.${rbdName} mon "allow r" osd "allow rwx pool ${rbdPoolName} object_prefix rbd_data.${imageID}; allow rwx pool ${rbdPoolName} object_prefix rbd_header.${imageID}; allow rx pool ${rbdPoolName} object_prefix rbd_id.${rbdName}; allow class rbd metadata_list pool ${rbdPoolName}" -o /etc/ceph/ceph.client.${rbdName}.keyring; With this newly generated keyring I can map the relevant RBD w/o errors. Many thanks to everybody who contributed to the solution. Am 27.02.2023 um 13:59 schrieb Curt:
Needs to be inside the " with your other commands.
On Mon, Feb 27, 2023, 16:55 Thomas Schneider <74cmonty@gmail.com> wrote:
Hi,
I get an error running this ceph auth get-or-create syntax:
# ceph auth get-or-create client.${rbdName} mon "allow r" osd "allow rwx pool ${rbdPoolName} object_prefix rbd_data.${imageID}; allow rwx pool ${rbdPoolName} object_prefix rbd_header.${imageID}; allow rx pool ${rbdPoolName} object_prefix rbd_id.${rbdName}"; allow class rbd metadata_list pool ${rbdPoolName} -o /etc/ceph/ceph.client.${rbdName}.keyring; [client.VCT] key = AQDGp/xj5EKrFRAArU7SyOVF8NFUC4lRCWwmCQ== -bash: allow: command not found.
THX
Am 26.02.2023 um 12:46 schrieb Ilya Dryomov: > allow class rbd metadata_list pool hdb_backup _______________________________________________ ceph-users mailing list -- ceph-users@ceph.io To unsubscribe send an email to ceph-users-leave@ceph.io