Hello ! Does someone manage to use mgmt-gateway, with a FQDN, and the monitoring stack working ? In my LAB, after upgrading from 10.2.3 to 20.2.0, My dashboard was working fine, with grafana dashboards. I decided to test mgmt-gateway. I use a VIP with a specific DNS name pointing at that VIP. I have a certificate generated with our internal PKI, valid for the DNS name and the VIP. Dashboard works, but no monitoring anymore. - Popups concerning alermanager : Failed to execute prometheus Error parsing Prometheus Alertmanager response: Expecting value 9/12/25 04:07 PM - No graphs in dashboard, with errors "origin not allowed" in each panel If I open Grafana directly, I see : - that the VIP is used, not my DNS name, but none works. - Grafana works but I can't see dashboards, and if I put a URL that should work (https://$VIP/grafana/d/edtb0oxdq/ceph-cluster), I have a message : Failed to load dashboard Unauthorized Some more infos : https://$DNS/grafana/dashboards => show the list of Dashboards Open a dashboard show errors 'origin not allowed" on panels https://$VIP/grafana/dashboards => cannot list the Dashboards, error Unauthorized Concerning the Altermanger errors, I see thoses XHR calls in my browser, ending in HTTP error 400 Bad Request : https://$DNS/api/prometheus?cluster_filter=true I opened an issue here : https://tracker.ceph.com/issues/74164 -- Gilles