That configuration is optimal for maximizing recovery times and write latency: since each EC set will span 8 hosts of 9, every time a host becames unavailable virtually all PGs will become degraded, and even with all host available any write will involve nearly all hosts.
This kind of optimal configuration is popular with those who think that the original design assumption of Ceph of having many, many more hosts and OSDs than the replication factor or stripe width was wasteful and cowardly. :-)
Isn't a bigger k+m a good things for performance if network and hardware not the bottleneck ?
Is there any particular reason why the failure domain is host but pods with 3 hosts get shut down?
I feel that it will give the same result as pods failure domain with the gain of loosing 3 hosts
Depends for what. But it is difficult to say without knowing the expected data and workload profiles.
Will be mostly bloc (virtual machine and kubernetes pods)
I might opine that in most cases it is as unimportant as having 'min_size=2' with 'size=3'. :-) "Safely" and 'k=5' with 'min_size=5' is an interesting association :-).
Asking just in case but already knew the answer I guess
Perhaps 'k=2,m=2' or for the very brave 'k=4,m=2'. But again it all depends on expected data and workload profiles.
Just downsize the profile to 4+3 as this cluster is in test phase (I want to keep this failure host domain and I believe this is the best to do ?) ________________________________ De : Peter Grandi via ceph-users <ceph-users@ceph.io> Envoyé : lundi 27 juillet 2026 12:15:47 À : list Linux fs Ceph Objet : [ceph-users] Re: Ec pool min size
We have a 9 hosts (3 per pod) cluster with 1 pool in EC 5+3 (host domain failure),
That configuration is optimal for maximizing recovery times and write latency: since each EC set will span 8 hosts of 9, every time a host becames unavailable virtually all PGs will become degraded, and even with all host available any write will involve nearly all hosts. This kind of optimal configuration is popular with those who think that the original design assumption of Ceph of having many, many more hosts and OSDs than the replication factor or stripe width was wasteful and cowardly. :-)
I expected that shutting down 1 pod
Is there any particular reason why the failure domain is host but pods with 3 hosts get shut down?
wouldn't affect our pg but I just discovered that the EC pool is in min_size 6 while trying it. Is min_size 6 important in this case ?
Depends for what. But it is difficult to say without knowing the expected data and workload profiles. I might opine that in most cases it is as unimportant as having 'min_size=2' with 'size=3'. :-)
Could I safely lower it to 5
"Safely" and 'k=5' with 'min_size=5' is an interesting association :-).
or using another EC k+m would suit better?
Perhaps 'k=2,m=2' or for the very brave 'k=4,m=2'. But again it all depends on expected data and workload profiles. _______________________________________________ ceph-users mailing list -- ceph-users@ceph.io To unsubscribe send an email to ceph-users-leave@ceph.io