On Nov 18, 2025, at 8:12 AM, Albert Shih <Albert.Shih@obspm.fr> wrote:
Le 18/11/2025 à 07:53:48-0500, Anthony D'Atri a écrit Hi,
# ceph fsid 44928f74-thx-1138-8862-d96497f06d07
Well, if I don't have the file the commande don't work
root@ceph:~# ceph fsid Error initializing cluster client: ObjectNotFound('RADOS object not found (error calling conf_read_file)') root@ceph:~#
You do need the conf file to point to the mons.
Or you could define a custom facter fact...
It's indeed what I'm doing with my puppet, but I need to known how to get that info.
Currently I have the facter running to get the fsid so I can use it in my puppet module, but the facter doesn't return anything when I don't have the file. That's why I'm thinking to create a cron with
rsync /etc/ceph/ceph.conf other_nodes:/etc/ceph
on the master node.
Just sayin...
... that said, before Mimic brought us the central config db, maintaining <clustername>.conf across clusters was a pain. When testing or troubleshooting one would need to persist changes across all nodes, and in the heat of an escalation it was all too easy to forget to persist changes. Even with the file templated in automation, consider what happens when an important change happens while one or more nodes is down ... then it comes back up.
No doubt but my question is what happens if I put the ceph.conf, can be any unexpected side effect.
Regards.
On Nov 18, 2025, at 4:41 AM, Albert Shih <Albert.Shih@obspm.fr> wrote:
Hi,
Just like to know if it's a bad idea (like something going to bite me in few year) to have a copy of the /etc/ceph/ceph.conf from the master copy on every node of the cluster (install with cephadm).
I «need» the ceph.conf to able to get the fsid on every node.
-- Albert SHIH 🦫 🐸 France Heure locale/Local time: mar. 18 nov. 2025 14:02:38 CET _______________________________________________ ceph-users mailing list -- ceph-users@ceph.io To unsubscribe send an email to ceph-users-leave@ceph.io