Hi Martin, Thanks for the suggestion. I'm not entirely sure what changed during the upgrade. I have more nodes in the same cluster and another cluster with additional nodes where the `ceph` user and group IDs are `64045`, and those are working without any issues. However, on the nodes that were upgraded, the OSDs failed with the permission errors. After changing the `ceph` UID/GID to `167`, everything started working correctly. Once again thanks for your help. ~ Jay. On Fri, Mar 13, 2026 at 1:07 PM Martin Andersen via ceph-users < ceph-users@ceph.io> wrote:
* Jay See via ceph-users <ceph-users@ceph.io> on Wed, 11 Mar 2026 at 09:41:
Hi all,
After upgrading a Ceph Reef (18.2.4) node from Ubuntu 20.04 (kernel 5.4.0) to Ubuntu 22.04 (kernel 5.15.0-94), a cephadm-managed OSD fails to start with a “Permission denied” error.
Hi Jay,
We had a similar issue when moving from 20.04 to 24.04 in a containerized setup. The issue for us turned out to be that Focal inherited the uids+gids from the OS into the containers, whereas Noble did not. Worth checking if it is the same on Jammy as well.
The logs will state that the osd mounts are chowned to ceph:ceph, sometimes
stating the actual numerical uid+gid (167:167). However, this turned out to be
misleading, and one had to manually set the uid+gids on the storage nodes as
these were set to a higher range than what was expected by the containers, thus
causing the “permission denied” error-
$ usermod -u 167 ceph ; groupmod -g 167 ceph ; reboot
--Martin _______________________________________________ ceph-users mailing list -- ceph-users@ceph.io To unsubscribe send an email to ceph-users-leave@ceph.io
-- P *SAVE PAPER – Please do not print this e-mail unless absolutely necessary.*