Ah, that was an easy fix. Great that you figured it out. Zitat von Maximilian Hill <max@maxhill.eu>:
I just solved the problem. One of the hosts bucket was incorrectly assigned to "root" directly instead of the correct "rack". After moving the "host" bucket it started working again.
On 2026-07-29 19:00, Eugen Block via ceph-users wrote:
Hi,
Draining a host doesn’t allow any backfill because there aren’t any hosts available to backfill to without breaking the crush rule.
I guess you were right about this.
Thanks for your help
On 2026-07-30 09:43, Eugen Block wrote:
That's not a good sign. Something else must have happenend after/while draining the node. Did other OSDs or hosts fail in the meantime so that there are not enough replicas to recover? Are all pools using the same crush rule? How exactly did you drain the node? Some more context and history are required to be able to find out what's going on.