I've faced a bug in sed for with_jaeger and patch it here: https://github.com/ceph/ceph/pull/38743
I've attached the git diff.

On Fri, Jan 1, 2021 at 8:27 PM Deepika Upadhyay <deepikaupadhyay01@gmail.com> wrote:
I tried to reproduce my system: fedora 32 + Ubuntu 18.04 with master, but seems to work fine there.
can you use git diff to see what updates were done in debian/control script when using install-deps and share that. Jaeger doesn't need pip for installing any dependency. 

On Fri, Jan 1, 2021 at 9:30 PM Seena Fallah <seenafallah@gmail.com> wrote:
python3-pip would be installed by install-deps.sh as before. I think something else is going wrong that python will now not install by with_jaeger!

On Fri, Jan 1, 2021 at 6:44 PM Deepika Upadhyay <deepikaupadhyay01@gmail.com> wrote:
aah, I see, we are missing pip3 package installation for make check, you can either skip FOR_MAKE_CHECK for now/open a PR for a fix, or install that (python3-pip) explicitly.
thanks for catching that!

On Fri, Jan 1, 2021 at 8:28 PM Seena Fallah <seenafallah@gmail.com> wrote:
I'm failing again with:

./install-deps.sh: line 389: virtualenv: command not found
 ./install-deps.sh: line 390: /ceph/install-deps-python3/bin/activate: No such file or directory
 ./install-deps.sh: line 377: pip: command not found

Command I run: FOR_MAKE_CHECK=1 WITH_JAEGER=1 ./install-deps.sh

On Fri, Jan 1, 2021 at 4:03 PM Deepika Upadhyay <deepikaupadhyay01@gmail.com> wrote:
hey Seena, 

It needs to have some dependencies updated using `WITH_JAEGER=true ./install.sh` should help install them.

On Fri, Jan 1, 2021 at 2:09 AM Seena Fallah <seenafallah@gmail.com> wrote:
I’m looking for a tracing in the OSD layer. It seems your branch is in the rgw layer :(

On Thu, Dec 31, 2020 at 9:45 PM Abhinav Singh <singhabhinav0796@gmail.com> wrote:
Hey seena, if you are building this branch for tracing purpose then I think you should, build my forked repo with https://github.com/suab321321/ceph/tree/wip-jaegerTracer-noNamespace. My branch is not merged with master and I have not updated it in long time so there many merge conflict with the master.

On Thu, 31 Dec, 2020, 10:48 pm Seena Fallah, <seenafallah@gmail.com> wrote:
make vstart failed with ./do_cmake.sh -DWITH_JAEGER=ON

 CMake Error at /usr/share/cmake-3.10/Modules/FindPackageHandleStandardArgs.cmake:137 (message):
7266  Could NOT find FLEX (missing: FLEX_EXECUTABLE)
7267 Call Stack (most recent call first):
7268  /usr/share/cmake-3.10/Modules/FindPackageHandleStandardArgs.cmake:378 (_FPHSA_FAILURE_MESSAGE)
7269  /usr/share/cmake-3.10/Modules/FindFLEX.cmake:217 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
7270  compiler/cpp/CMakeLists.txt:25 (find_package)
7271 -- Configuring incomplete, errors occurred!
7272 See also "/ceph/build/external/thrift/CMakeFiles/CMakeOutput.log".
7273 See also "/ceph/build/external/thrift/CMakeFiles/CMakeError.log".
7274 make[3]: *** [external/thrift/src/thrift-stamp/thrift-configure] Error 1
7275 src/CMakeFiles/thrift.dir/build.make:106: recipe for target 'external/thrift/src/thrift-stamp/thrift-configure' failed
7276 CMakeFiles/Makefile2:1384: recipe for target 'src/CMakeFiles/thrift.dir/all' failed
7277 make[2]: *** [src/CMakeFiles/thrift.dir/all] Error 2
7278 make[2]: *** Waiting for unfinished jobs....
Dev mailing list -- dev@ceph.io
To unsubscribe send an email to dev-leave@ceph.io
Dev mailing list -- dev@ceph.io
To unsubscribe send an email to dev-leave@ceph.io