cephadm not working with non-root user
Hi, I am trying to install ceph 'octopus' using cephadm. In bootstrap command, I have specified a non-root user account as ssh-user. cephadm bootstrap --mon-ip xx.xxx.xx.xx --ssh-user non-rootuser when bootstrap about to complete it threw an error stating. """" INFO:cephadm:Non-zero exit code 2 from /usr/bin/podman run --rm --net=host --ipc=host -e CONTAINER_IMAGE=docker.io/ceph/ceph:v15 -e NODE_NAME=node1 - v /var/log/ceph/ae4ed114-e145-11ea-9c1f-0025900a8ebe:/var/log/ceph:z -v /tmp/ceph-tmpm22k9j9w:/etc/ceph/ceph.client.admin.keyring:z -v /tmp/ceph-tmpe 1ltigk8:/etc/ceph/ceph.conf:z --entrypoint /usr/bin/ceph docker.io/ceph/ceph:v15 orch host add node1 INFO:cephadm:/usr/bin/ceph:stderr Error ENOENT: Failed to connect to node1 (node1). INFO:cephadm:/usr/bin/ceph:stderr Check that the host is reachable and accepts connections using the cephadm SSH key INFO:cephadm:/usr/bin/ceph:stderr INFO:cephadm:/usr/bin/ceph:stderr you may want to run: INFO:cephadm:/usr/bin/ceph:stderr > ceph cephadm get-ssh-config > ssh_config INFO:cephadm:/usr/bin/ceph:stderr > ceph config-key get mgr/cephadm/ssh_identity_key > key INFO:cephadm:/usr/bin/ceph:stderr > ssh -F ssh_config -i key root@node1 """"" In the above steps, it's trying to connect as root to the node and when I downloaded ssh_config file it was also specified as 'root' inside. so, I modified the config file and uploaded but same to ceph but still ssh to node1 is not working. To confirm if I have used the right command been used during bootstrap. I have tried the below command. " ceph config-key dump mgr/cephadm/ssh_user" { "mgr/cephadm/ssh_user": "non-rootuser" } and the output shows the user I have used during bootstrap "non-rootuser" but at the same time when I run cmd " ceph cephadm get-user " the output still shows 'root' as the user. Why the change is not affecting? do anyone faced a similar issue in bootstrap? Is there any way to avoid using container with cephadm? regards Amudhan
Hi, Any of you used cephadm bootstrap command without root user? On Wed, Aug 19, 2020 at 11:30 AM Amudhan P <amudhan83@gmail.com> wrote:
Hi,
I am trying to install ceph 'octopus' using cephadm. In bootstrap command, I have specified a non-root user account as ssh-user. cephadm bootstrap --mon-ip xx.xxx.xx.xx --ssh-user non-rootuser
when bootstrap about to complete it threw an error stating.
"""" INFO:cephadm:Non-zero exit code 2 from /usr/bin/podman run --rm --net=host --ipc=host -e CONTAINER_IMAGE=docker.io/ceph/ceph:v15 -e NODE_NAME=node1 - v /var/log/ceph/ae4ed114-e145-11ea-9c1f-0025900a8ebe:/var/log/ceph:z -v /tmp/ceph-tmpm22k9j9w:/etc/ceph/ceph.client.admin.keyring:z -v /tmp/ceph-tmpe 1ltigk8:/etc/ceph/ceph.conf:z --entrypoint /usr/bin/ceph docker.io/ceph/ceph:v15 orch host add node1 INFO:cephadm:/usr/bin/ceph:stderr Error ENOENT: Failed to connect to node1 (node1). INFO:cephadm:/usr/bin/ceph:stderr Check that the host is reachable and accepts connections using the cephadm SSH key INFO:cephadm:/usr/bin/ceph:stderr INFO:cephadm:/usr/bin/ceph:stderr you may want to run: INFO:cephadm:/usr/bin/ceph:stderr > ceph cephadm get-ssh-config > ssh_config INFO:cephadm:/usr/bin/ceph:stderr > ceph config-key get mgr/cephadm/ssh_identity_key > key INFO:cephadm:/usr/bin/ceph:stderr > ssh -F ssh_config -i key root@node1 """"" In the above steps, it's trying to connect as root to the node and when I downloaded ssh_config file it was also specified as 'root' inside. so, I modified the config file and uploaded but same to ceph but still ssh to node1 is not working.
To confirm if I have used the right command been used during bootstrap. I have tried the below command.
" ceph config-key dump mgr/cephadm/ssh_user" { "mgr/cephadm/ssh_user": "non-rootuser" }
and the output shows the user I have used during bootstrap "non-rootuser"
but at the same time when I run cmd " ceph cephadm get-user " the output still shows 'root' as the user.
Why the change is not affecting? do anyone faced a similar issue in bootstrap?
Is there any way to avoid using container with cephadm?
regards Amudhan
participants (1)
-
Amudhan P