Balancer configuration fails with Error EINVAL: unrecognized config option 'mgr/balancer/max_misplaced'
Hi, I want to adjust balancer throttling and executed this command that returns an error: root@ld3955:~# ceph config set mgr mgr/balancer/max_misplaced .01 Error EINVAL: unrecognized config option 'mgr/balancer/max_misplaced' root@ld3955:~# ceph balancer status { "active": true, "plans": [], "mode": "upmap" } Ceph is healthy, though: root@ld3955:~# ceph -s cluster: id: 6b1b5117-6e08-4843-93d6-2da3cf8a6bae health: HEALTH_WARN mon ld5505 is low on available space services: mon: 3 daemons, quorum ld5505,ld5506,ld5507 (age 19h) mgr: ld5507(active, since 23h), standbys: ld5506, ld5505, ld5508 mds: cephfs:1 {0=ld4464=up:active} 1 up:standby osd: 442 osds: 442 up, 442 in data: pools: 6 pools, 8312 pgs objects: 62.07M objects, 237 TiB usage: 710 TiB used, 821 TiB / 1.5 PiB avail pgs: 8312 active+clean io: client: 1.3 KiB/s rd, 913 KiB/s wr, 1 op/s rd, 34 op/s wr Can you please advise howto adjust balancer throttling? THX
This option have been replaced with "target_max_misplaced_ratio" since Nautilus v1.14.0 See description about "target_max_misplaced_ratio" in changelog here https://docs.ceph.com/docs/master/releases/nautilus/ Thomas Schneider <74cmonty@gmail.com> 於 2019年11月4日 週一 下午5:00寫道:
Hi,
I want to adjust balancer throttling and executed this command that returns an error: root@ld3955:~# ceph config set mgr mgr/balancer/max_misplaced .01 Error EINVAL: unrecognized config option 'mgr/balancer/max_misplaced'
root@ld3955:~# ceph balancer status { "active": true, "plans": [], "mode": "upmap" }
Ceph is healthy, though: root@ld3955:~# ceph -s cluster: id: 6b1b5117-6e08-4843-93d6-2da3cf8a6bae health: HEALTH_WARN mon ld5505 is low on available space
services: mon: 3 daemons, quorum ld5505,ld5506,ld5507 (age 19h) mgr: ld5507(active, since 23h), standbys: ld5506, ld5505, ld5508 mds: cephfs:1 {0=ld4464=up:active} 1 up:standby osd: 442 osds: 442 up, 442 in
data: pools: 6 pools, 8312 pgs objects: 62.07M objects, 237 TiB usage: 710 TiB used, 821 TiB / 1.5 PiB avail pgs: 8312 active+clean
io: client: 1.3 KiB/s rd, 913 KiB/s wr, 1 op/s rd, 34 op/s wr
Can you please advise howto adjust balancer throttling?
THX _______________________________________________ ceph-users mailing list -- ceph-users@ceph.io To unsubscribe send an email to ceph-users-leave@ceph.io
participants (2)
-
Thomas Schneider
-
王予智