Broken dashboard after upgrade to 20.2.0
Dear Ceph users, I just successfully upgraded my cehpadm-managed cluster to 20.2.0, but the status reports the following error: Module 'dashboard' has failed: No module named 'smb' I upgraded using my self-built Ceph image based on Ubuntu 22.04 and making use of the official Ceph .deb packages, and I noticed that the pysmb package was actually not present. So I rebuilt another image in which I install it with sudo pip3 install pysmb (since I found no .deb), and this should have fixed the problem since from a shell in a container I can launch python3 and load the smb module. But still I get the dashboard error, even after restarting the managers, and the dashboard is unreachable. Any hint about how can I fix this? Thank you, Nicola
I found that the error is reproducible from Ceph CLI: # ceph dashboard get-prometheus-api-host Error EIO: Module 'dashboard' has experienced an error and cannot handle commands: No module named 'smb' Any hint?
participants (1)
-
Nicola Mori