Version of podman for Ceph 15.2.10
Hello, I would like to install Ceph 15.2.10 using cephadm and just found the following table by checking the requirements on the host: https://docs.ceph.com/en/latest/cephadm/compatibility/#compatibility-with-po... Do I understand this table correctly that I should be using podman version 2.1? and what happens if I use the latest podman version 3.0 Best regards, Mabi
The latest podman 3.0.1 release is fine (we have many production clusters running this). We have not tested 3.1 yet, however, but will soon.
On Apr 8, 2021, at 10:32, mabi <mabi@protonmail.ch> wrote:
Hello,
I would like to install Ceph 15.2.10 using cephadm and just found the following table by checking the requirements on the host:
https://docs.ceph.com/en/latest/cephadm/compatibility/#compatibility-with-po...
Do I understand this table correctly that I should be using podman version 2.1?
and what happens if I use the latest podman version 3.0
Best regards, Mabi
_______________________________________________ ceph-users mailing list -- ceph-users@ceph.io To unsubscribe send an email to ceph-users-leave@ceph.io
Thank you for confirming that podman 3.0.1 is fine. I have now bootstrapped my first node with cephadm bootstrap command on my RasPi 4 (8GB RAM) with Ubuntu 20.04 LTS that worked well but in the logs I can see that it fails to deploy the graphana container as you can see from the log below: Traceback (most recent call last): File "/usr/share/ceph/mgr/cephadm/module.py", line 1021, in _remote_connection yield (conn, connr) File "/usr/share/ceph/mgr/cephadm/module.py", line 1168, in _run_cephadm code, '\n'.join(err))) orchestrator._interface.OrchestratorError: cephadm exited with an error code: 1, stderr:Deploy daemon grafana.ceph1a ... Non-zero exit code 1 from /usr/bin/podman run --rm --ipc=host --net=host --entrypoint stat -e CONTAINER_IMAGE=docker.io/ceph/ceph-grafana:6.7.4 -e NODE_NAME=ceph1a docker.io/ceph/ceph-grafana:6.7.4 -c %u %g /var/lib/grafana stat: stderr {"msg":"exec container process `/usr/bin/stat`: Exec format error","level":"error","time":"2021-04-09T06:17:54.000910863Z"} Traceback (most recent call last): File "<stdin>", line 6153, in <module> File "<stdin>", line 1412, in _default_image File "<stdin>", line 3431, in command_deploy File "<stdin>", line 3362, in extract_uid_gid_monitoring File "<stdin>", line 2099, in extract_uid_gid RuntimeError: uid/gid not found Does anyone have a clue what could be going wrong here?? and how to fix that? Right now my bootstraped node has the following containers running: $ sudo podman ps CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES 5985c38ef718 docker.io/ceph/ceph:v15 -n mon.ceph1a -f ... 15 hours ago Up 15 hours ago ceph-8d47792c-987d-11eb-9bb6-a5302e00e1fa-mon.ceph1a 0773ea8c6951 docker.io/ceph/ceph:v15 -n mgr.ceph1a.rzc... 15 hours ago Up 15 hours ago ceph-8d47792c-987d-11eb-9bb6-a5302e00e1fa-mgr.ceph1a.rzcwjd 941db20cdc2e docker.io/ceph/ceph:v15 -n client.crash.c... 15 hours ago Up 15 hours ago ceph-8d47792c-987d-11eb-9bb6-a5302e00e1fa-crash.ceph1a 897286d3c80f docker.io/prom/node-exporter:v0.18.1 --no-collector.ti... 15 hours ago Up 15 hours ago ceph-8d47792c-987d-11eb-9bb6-a5302e00e1fa-node-exporter.ceph1a 08c4e95c0c03 docker.io/prom/prometheus:v2.18.1 --config.file=/et... 15 hours ago Up 15 hours ago ceph-8d47792c-987d-11eb-9bb6-a5302e00e1fa-prometheus.ceph1a 19944dbf7a63 docker.io/prom/alertmanager:v0.20.0 --web.listen-addr... 15 hours ago Up 15 hours ago ceph-8d47792c-987d-11eb-9bb6-a5302e00e1fa-alertmanager.ceph1a ‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐ On Friday, April 9, 2021 3:37 AM, David Orman <ormandj@corenode.com> wrote:
The latest podman 3.0.1 release is fine (we have many production clusters running this). We have not tested 3.1 yet, however, but will soon.
On Apr 8, 2021, at 10:32, mabi mabi@protonmail.ch wrote: Hello, I would like to install Ceph 15.2.10 using cephadm and just found the following table by checking the requirements on the host: https://docs.ceph.com/en/latest/cephadm/compatibility/#compatibility-with-po... Do I understand this table correctly that I should be using podman version 2.1? and what happens if I use the latest podman version 3.0 Best regards, Mabi
ceph-users mailing list -- ceph-users@ceph.io To unsubscribe send an email to ceph-users-leave@ceph.io
ceph-users mailing list -- ceph-users@ceph.io To unsubscribe send an email to ceph-users-leave@ceph.io
That container (ceph-grafana) is not built for ARM based processors, only AMD64: https://hub.docker.com/r/ceph/ceph-grafana/tags?page=1&ordering=last_updated . You'll probably need to disable that (I think it's part of the dashboard module - I don't know - we run our own Prometheus/Grafana infrastructure outside of Ceph). On Fri, Apr 9, 2021 at 1:32 AM mabi <mabi@protonmail.ch> wrote:
Thank you for confirming that podman 3.0.1 is fine.
I have now bootstrapped my first node with cephadm bootstrap command on my RasPi 4 (8GB RAM) with Ubuntu 20.04 LTS that worked well but in the logs I can see that it fails to deploy the graphana container as you can see from the log below:
Traceback (most recent call last): File "/usr/share/ceph/mgr/cephadm/module.py", line 1021, in _remote_connection yield (conn, connr) File "/usr/share/ceph/mgr/cephadm/module.py", line 1168, in _run_cephadm code, '\n'.join(err))) orchestrator._interface.OrchestratorError: cephadm exited with an error code: 1, stderr:Deploy daemon grafana.ceph1a ... Non-zero exit code 1 from /usr/bin/podman run --rm --ipc=host --net=host --entrypoint stat -e CONTAINER_IMAGE=docker.io/ceph/ceph-grafana:6.7.4 -e NODE_NAME=ceph1a docker.io/ceph/ceph-grafana:6.7.4 -c %u %g /var/lib/grafana stat: stderr {"msg":"exec container process `/usr/bin/stat`: Exec format error","level":"error","time":"2021-04-09T06:17:54.000910863Z"} Traceback (most recent call last): File "<stdin>", line 6153, in <module> File "<stdin>", line 1412, in _default_image File "<stdin>", line 3431, in command_deploy File "<stdin>", line 3362, in extract_uid_gid_monitoring File "<stdin>", line 2099, in extract_uid_gid RuntimeError: uid/gid not found
Does anyone have a clue what could be going wrong here?? and how to fix that?
Right now my bootstraped node has the following containers running:
$ sudo podman ps CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES 5985c38ef718 docker.io/ceph/ceph:v15 -n mon.ceph1a -f ... 15 hours ago Up 15 hours ago ceph-8d47792c-987d-11eb-9bb6-a5302e00e1fa-mon.ceph1a 0773ea8c6951 docker.io/ceph/ceph:v15 -n mgr.ceph1a.rzc... 15 hours ago Up 15 hours ago ceph-8d47792c-987d-11eb-9bb6-a5302e00e1fa-mgr.ceph1a.rzcwjd 941db20cdc2e docker.io/ceph/ceph:v15 -n client.crash.c... 15 hours ago Up 15 hours ago ceph-8d47792c-987d-11eb-9bb6-a5302e00e1fa-crash.ceph1a 897286d3c80f docker.io/prom/node-exporter:v0.18.1 --no-collector.ti... 15 hours ago Up 15 hours ago ceph-8d47792c-987d-11eb-9bb6-a5302e00e1fa-node-exporter.ceph1a 08c4e95c0c03 docker.io/prom/prometheus:v2.18.1 --config.file=/et... 15 hours ago Up 15 hours ago ceph-8d47792c-987d-11eb-9bb6-a5302e00e1fa-prometheus.ceph1a 19944dbf7a63 docker.io/prom/alertmanager:v0.20.0 --web.listen-addr... 15 hours ago Up 15 hours ago ceph-8d47792c-987d-11eb-9bb6-a5302e00e1fa-alertmanager.ceph1a
‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐ On Friday, April 9, 2021 3:37 AM, David Orman <ormandj@corenode.com> wrote:
The latest podman 3.0.1 release is fine (we have many production clusters running this). We have not tested 3.1 yet, however, but will soon.
On Apr 8, 2021, at 10:32, mabi mabi@protonmail.ch wrote: Hello, I would like to install Ceph 15.2.10 using cephadm and just found the following table by checking the requirements on the host: https://docs.ceph.com/en/latest/cephadm/compatibility/#compatibility-with-po... Do I understand this table correctly that I should be using podman version 2.1? and what happens if I use the latest podman version 3.0 Best regards, Mabi
ceph-users mailing list -- ceph-users@ceph.io To unsubscribe send an email to ceph-users-leave@ceph.io
ceph-users mailing list -- ceph-users@ceph.io To unsubscribe send an email to ceph-users-leave@ceph.io
I see, I guess I can live without grafana anyway. What would be the "cephadm bootstrap" command or parameter in order to skip installing grafana? And now that it is already installed which command can I use to disable it? It is trying to get deployed every 10 minutes... ‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐ On Friday, April 9, 2021 2:32 PM, David Orman <ormandj@corenode.com> wrote:
That container (ceph-grafana) is not built for ARM based processors, only AMD64: https://hub.docker.com/r/ceph/ceph-grafana/tags?page=1&ordering=last_updated . You'll probably need to disable that (I think it's part of the dashboard module - I don't know - we run our own Prometheus/Grafana infrastructure outside of Ceph).
On Fri, Apr 9, 2021 at 1:32 AM mabi mabi@protonmail.ch wrote:
Thank you for confirming that podman 3.0.1 is fine. I have now bootstrapped my first node with cephadm bootstrap command on my RasPi 4 (8GB RAM) with Ubuntu 20.04 LTS that worked well but in the logs I can see that it fails to deploy the graphana container as you can see from the log below: Traceback (most recent call last): File "/usr/share/ceph/mgr/cephadm/module.py", line 1021, in _remote_connection yield (conn, connr) File "/usr/share/ceph/mgr/cephadm/module.py", line 1168, in _run_cephadm code, '\n'.join(err))) orchestrator._interface.OrchestratorError: cephadm exited with an error code: 1, stderr:Deploy daemon grafana.ceph1a ... Non-zero exit code 1 from /usr/bin/podman run --rm --ipc=host --net=host --entrypoint stat -e CONTAINER_IMAGE=docker.io/ceph/ceph-grafana:6.7.4 -e NODE_NAME=ceph1a docker.io/ceph/ceph-grafana:6.7.4 -c %u %g /var/lib/grafana stat: stderr {"msg":"exec container process `/usr/bin/stat`: Exec format error","level":"error","time":"2021-04-09T06:17:54.000910863Z"} Traceback (most recent call last): File "<stdin>", line 6153, in <module> File "<stdin>", line 1412, in _default_image File "<stdin>", line 3431, in command_deploy File "<stdin>", line 3362, in extract_uid_gid_monitoring File "<stdin>", line 2099, in extract_uid_gid RuntimeError: uid/gid not found Does anyone have a clue what could be going wrong here?? and how to fix that? Right now my bootstraped node has the following containers running: $ sudo podman ps CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES 5985c38ef718 docker.io/ceph/ceph:v15 -n mon.ceph1a -f ... 15 hours ago Up 15 hours ago ceph-8d47792c-987d-11eb-9bb6-a5302e00e1fa-mon.ceph1a 0773ea8c6951 docker.io/ceph/ceph:v15 -n mgr.ceph1a.rzc... 15 hours ago Up 15 hours ago ceph-8d47792c-987d-11eb-9bb6-a5302e00e1fa-mgr.ceph1a.rzcwjd 941db20cdc2e docker.io/ceph/ceph:v15 -n client.crash.c... 15 hours ago Up 15 hours ago ceph-8d47792c-987d-11eb-9bb6-a5302e00e1fa-crash.ceph1a 897286d3c80f docker.io/prom/node-exporter:v0.18.1 --no-collector.ti... 15 hours ago Up 15 hours ago ceph-8d47792c-987d-11eb-9bb6-a5302e00e1fa-node-exporter.ceph1a 08c4e95c0c03 docker.io/prom/prometheus:v2.18.1 --config.file=/et... 15 hours ago Up 15 hours ago ceph-8d47792c-987d-11eb-9bb6-a5302e00e1fa-prometheus.ceph1a 19944dbf7a63 docker.io/prom/alertmanager:v0.20.0 --web.listen-addr... 15 hours ago Up 15 hours ago ceph-8d47792c-987d-11eb-9bb6-a5302e00e1fa-alertmanager.ceph1a ‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐ On Friday, April 9, 2021 3:37 AM, David Orman ormandj@corenode.com wrote:
The latest podman 3.0.1 release is fine (we have many production clusters running this). We have not tested 3.1 yet, however, but will soon.
On Apr 8, 2021, at 10:32, mabi mabi@protonmail.ch wrote: Hello, I would like to install Ceph 15.2.10 using cephadm and just found the following table by checking the requirements on the host: https://docs.ceph.com/en/latest/cephadm/compatibility/#compatibility-with-po... Do I understand this table correctly that I should be using podman version 2.1? and what happens if I use the latest podman version 3.0 Best regards, Mabi ceph-users mailing list -- ceph-users@ceph.io To unsubscribe send an email to ceph-users-leave@ceph.io
ceph-users mailing list -- ceph-users@ceph.io To unsubscribe send an email to ceph-users-leave@ceph.io
ceph-users mailing list -- ceph-users@ceph.io To unsubscribe send an email to ceph-users-leave@ceph.io
participants (2)
-
David Orman
-
mabi